close
Top Panel
Top Panel
Top Panel
UC: VG202 and Fax machine with CCME integration PDF Print E-mail
Written by Alexei Spirin   
Friday, 09 July 2010 21:54

This is a VG202 config with Fax machine. Provide interoperability with Cisco Call Manager Express.

UC IOS Config: VG202 with Fax machine and CCME uplink
version 15.0
no service pad
service timestamps debug datetime localtime
service timestamps log datetime localtime
service password-encryption
!
hostname VG202-branch
!
boot-start-marker
boot system flash flash:/vg20x-advipservicesk9-mz.150-1.M2.bin
boot system flash flash:/vg20x-advipservicesk9-mz.124-22.T4.bin
boot-end-marker
!
logging buffered 64000
no logging console
enable secret PLeaseChangeMe!
!
aaa new-model
!
!
aaa authentication login default group tacacs+ local
aaa authorization exec default group tacacs+ local
aaa accounting exec default
action-type start-stop
group tacacs+
!
aaa accounting commands 15 default
action-type start-stop
group tacacs+
!
!
!
!
!
!
aaa session-id common
clock timezone CEST 1
clock summer-time CEST recurring last Sun Mar 2:00 last Sun Oct 3:00
!
!
no ip source-route
!
!
!
!
ip cef
ip domain name company.local
no ipv6 cef
!
stcapp ccm-group 1
stcapp
!
stcapp feature access-code
!
stcapp feature speed-dial
!
!
!
stcapp supplementary-services
port 0/0
fallback-dn 2010
!
!
!
!
!
voice service voip
fax protocol pass-through g711ulaw
voice class codec 1
codec preference 1 g711ulaw
codec preference 2 g729r8
codec preference 3 g711alaw
!
!
!
!
voice-card 0
!
archive
log config
hidekeys
username Administrator privilege 15 secret PLeaseChangeMe!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 172.16.255.17 255.255.255.255
!
interface FastEthernet0/0
ip address 172.17.17.17 255.255.255.0
no ip redirects
no ip proxy-arp
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
ip route 0.0.0.0 0.0.0.0 172.17.17.1 !To reach CCME behind 3750 switch
ip tacacs source-interface Loopback0
!
ip access-list standard SnmpMonitor
permit 10.130.40.0 0.0.0.255
ip access-list standard TrustedNTP
permit 10.130.40.50
permit 10.130.40.51
deny any log
!
logging trap debugging
logging source-interface Loopback0
logging 10.130.40.40
!
!
!
!
snmp-server community PLeaseChangeMe! RO SnmpMonitor
!
tacacs-server host 10.130.40.10 key PLeaseChangeMe!
!
control-plane
!
!
voice-port 0/0
timeouts initial 60
timeouts interdigit 60
timeouts ringing infinity
caller-id enable
!
voice-port 0/1
!
ccm-manager sccp local FastEthernet0/0
!
!
sccp local FastEthernet0/0
sccp ccm 172.16.16.16 identifier 10 version 7.0
sccp
!
sccp ccm group 1
associate ccm 10 priority 1
!
dial-peer voice 999000 pots
service stcapp
port 0/0
!
!
!
!
line con 0
logging synchronous
no modem enable
line aux 0
line vty 0 4
session-timeout 45
logging synchronous
transport input ssh
transport output none
!
exception data-corruption buffer truncate
ntp source Loopback0
ntp server 10.130.40.50 prefer
ntp server 10.130.40.51
end
Last Updated on Friday, 09 July 2010 22:01